Route GuidesRoutes City GuidesCities Map Log in

Suddenly I cant download gpx files!

23 Mar 2019
Find a better bike route. Try our map & route-planner »

Become a supporter

Hi, I really like cycle.travel. Used it last week for a trip to portsmouth.

We are planning a trip back to uk from Naples in a month. I want to use OSMAND with cycle.travel routes.

I have a problem - can anyone help.

I plan to take an old but good chinese inew android 5.1 phone for cycle.travel gpx downloads, all my route storage and osmand use. I will have my other phone for nav backup and making calls etc.

The problem is, all of a sudden I cannot download c-t gpx files to the inew phone. I get a stuttering download icon, it says the download is queued and then fails. My other phone and 2 tablets work fine! I reset the inew but its still the same. Loads of storage.

The route Ive repeatedly been trying to download is small (Newton Abbot area to West Lulworth)

Any ideas?

Comments

Mon 25 Mar 2019, 12:28

I suffer that on my phone sometimes. I have to go into "Download" and then click on the failed one, then pick "Retry" and repeat a few times before it downloads.

Tablet and laptop work fine with the same route. Sometimes even the phone will work fine with the same route some time later. I think Android phone browsers are a bit fragile, or maybe a bit zealous at killing demanding scripts.

Mon 25 Mar 2019, 22:51

Update.

I have various old phones and tablets and was hoping to use 2 of them on my trip.

1 x android 2.x

1x android 6

3 x devices with android 5.1

It has now become clear that NONE of the 5.1 devices can download GPX files from this site. (They CAN download pdfs from this site). Otherwise they perform perfectly, downloading from other sites and using the app store.

Both my other devices work fine with this site.

This is most odd. My question is - is this something to do with the site? Any ideas.

Tue 26 Mar 2019, 09:36

Hm – that is strange. Does it work differently if you try a different browser on your phone (e.g. Firefox instead of Chrome)?

Tue 26 Mar 2019, 15:07

Thanks. I tried a different browser on one phone - same result. I've also done a full reset - same. I am pretty sure it worked about 10 days ago and stopped suddenly.

I thought you might have blacklisted me, I've used the site so much recently evaluating nav apps etc ;) I can get round it by using the android 6 phone but it is most odd.

Sun 7 Jun, 12:18

Sorry to raise this again, but I have just tried to download gpx route files to my Samsung Galaxy S8+ android phone running android version 9 and get the same results above. The GPX file isn't downloaded on to the phone - I use ES File Explorer to view recent files. As above, I can download the pdf file and it gets created in the download folder on the phone.

Any ideas how to fix this? I would like to create routes using cycle.travel and import them into other tools e.g. osmand.

As a side note, I would like to import them in to Garmin Connect as a new route on my phone, but think this isn't possible on the phone version of Garmin Connect (it works ok on a computer and iPad, but I don't want to take a computer or iPad on my travels). Ultimately, I want to download the route on to my Garmin 1030 cycle computer. Does anyone have any idea how to do this without using a computer or ipad?

Mon 8 Jun, 11:16

Can you give an example of a route where this happens, and how you’re trying to download it? (i.e. GPX track or route, from the map page or the journeys page, etc…)

Tue 9 Jun, 12:17

I have a route called Real Milk Co On Road which I have just tried to download from the journeys page and the map page. It has failed to download in both cases. I have just tried to download pdf again from the maps page and it has worked again.

Thanks for your help.

Tue 9 Jun, 12:28

FYI

I've just tried a different route (GBC 01) and it hasn't downloaded on my phone, but has worked OK on my PC.

Tue 9 Jun, 12:45

Solved!

I always use the default Samsung browser on my phone for the internet. I've just switched to Chrome and it's worked. It actually asked for permission to access the local files which the Samsung browser doesn't. The gpx download appears in the download folder as expected.

Thanks Again....

I now need to work out how to get it on to my Garmin 1030 from the phone - and I've just solved that by using Chrome on my phone to log in to Garmin Connect web app and importing the gpx download to create a new course. I can then use the Garmin Connect app installed on my phone to transfer it to my Garmin device. Of course I will need an internet connection on my travels to do all this - so it may not work all the time.