Route GuidesRoutes City GuidesCities Map My

TCX files missing cue sheet data

21 Mar 2018
Find a better bike route. Try our map & route-planner »

Become a supporter

I use an app on my phone (Bike Tracker) for turn by turn navigation which uses TCX files. When I export a TCX file from cycle.travel, a lot of the cue sheet information seems to be changed / missing / abbreviated. For example, I live in a suburb of Manchester, and while in the area, the cue sheet information on the laptop will show "turn left onto ... Road" but the information in the TCX file just shows "left Manchester". Why the loss of info ?

Comments

Fri 23 Mar 2018, 12:37

The official specification for TCX says that coursepoint names can't have more than 10 characters, so there's a limit to what it can fit in. But that said, it should be choosing the road name rather than the city name usually. Could you give an example where it's getting it wrong?

Fri 23 Mar 2018, 17:26

Hi Richard - thanks for getting back to me on this. First can I say that the route choices from cycle.travel are exactly what I am looking for. You really have an excellent site for route planning.

Looking at the file contents from the different GPS export options :-

  1. GPX track contains a list of "trkpt" with lat and long.
  2. GPX route contains a list of "rtept" with lat and long
  3. TCX course contains a list of "trackpoint" followed by a list of "coursepoint"
  4. TCX activity contains a list of "trackpoint"

It is the 3rd type which appears to me to have the missing info in the coursepoints. An example of this is the following course point which on the website says "Turn Right onto Hazelwood Road" :- 

<CoursePoint>
  <Name>Manchester</Name>
  <Time>2018-03-23T16:21:37Z</Time>
  <Position>
    <LatitudeDegrees>53.37838</LatitudeDegrees>
    <LongitudeDegrees>-2.11471</LongitudeDegrees>
  </Position>
  <PointType>Right</PointType>
</CoursePoint>
Notice : No mention of Hazelwood Road.

Just looking in a TCX file output (from RideWithGPS) that works fine in my turn by turn app, it has :-

<CoursePoint>
  <Name>Hazelwood</Name>
  <Time>2018-03-23T16:10:55Z</Time>
  <Position>
    <LatitudeDegrees>53.37838</LatitudeDegrees>
    <LongitudeDegrees>-2.11471</LongitudeDegrees>
  </Position>
  <PointType>Right</PointType>
  <Notes>Turn right onto Hazelwood Road</Notes>
</CoursePoint>
The difference is the <Notes> line which has the turn instruction. I don't know if this is part of the official TCX spec or if it's just some sort of work around. I think the data in <Name> is irrelevant.

Hope that helps. 

Sat 24 Mar 2018, 14:46

Ah, that’s interesting – thanks for spotting. Ok, I’ll take a look at putting the full information in the Notes field. (Garmin are pretty terrible at documenting what any of these stuff ever does!)

Tue 27 Mar 2018, 23:09

This should be up and running now. Let me know how it works for you.

Thu 29 Mar 2018, 17:35

Have created a route and looked at the output in the TCX file and it all looks good. Will see if I can get out on a ride this weekend to check it works in my turn by turn app. 

Many thanks for looking at and sorting that so promptly.

Fri 30 Mar 2018, 11:44

Did a short ride this morning. My turn by turn app worked fine with this new format TCX file. Thanks again. 

Fri 28 Sep 2018, 16:53

Hallo, try to load route into 'Bike Tracker' (tcx like suggested in this post), but message :'this file contains fewer than three turn-by-turn directions and cannot be used to speak a route. Other route planner for tcx (track and route points) with same result. Do you have a idea? Thanks in advance. Tony

Mon 1 Oct 2018, 19:09

Could you give me an example of a journey that doesn't work?

Mon 25 Mar, 19:55

I realise this is an old thread, but im having a similar issue to both John Ellerton and toplbike.

Ive noticed the abbreviations of turn by turn directions when i export as a tcx into something like 'ride with gps'. Some directions it reads the <notes> section perfectly, so I get a full direction like 'turn left onto clifton road' and other times I get just the <name> place holder so 'servicero' rather than 'continue on service ro'. This is within a single route, so Im not sure what is in the file that is making it swap between <name> infor or <notes> info. I certainly cant see anything when lookign at the file in notepad, it looks like it should work fine.

I also suffer the problem toplbike had when trying to read the same tcx file directly with 'bike tracker', you get the message ''this file contains fewer than three turn-by-turn directions and cannot be used to speak a route". Im wondering if the two problems are connected.

Wed 5 Jun, 22:56

Haven't looked on here for a long while. Don't know if anything has happened. This is my take on the above :-

1. Re:  the "fewer than three turn-by-turn directions" message - is because not all TCX files contain the turn instruction - in the GPS  option you must choose the third option (TCX course). If you choose the fourth option (TCX activity) there are no turn instructions included in the file, and that's what Bike Tracker is telling you.

2. Re: the other problem with the turn direction being incorrect, I have had a little play and can see examples of what you say. To me, the TCX file from cycle.travel looks correct to me, and from my experience they work fine with Bike Tracker. 

To me the problem you are seeing is that RideWithGPS is not interpreting the TCX file correctly. If you click on a turn instruction in the left hand column, you can see that turn instructions are normally split into 2 sections - a "Type" and "Note". Those that are interpreted incorrectly are split into 3 sections - a "Type", a "Note" and a "Description". TCX files from RideWithGPS files don't include a "description" line, so why this is shown, I don't know - ask RideWithGPS !

I've loaded the same file into Plotaroute and it's interpreted correctly there. I'm therefore convinced that the problem is definitely with RideWithGPS.

I know that Bike Tracker links directly to your RideWithGPS routes, and it's a bit of a pain getting the TCX file from cycle.travel onto your phone, but it looks like the only way we can use both Bike Tracker and cycle.travel is to manually download the TCX course file onto your phone. 

Sat 31 Aug, 22:44

I had another look at the problem of TCX files from cycle.travel not being interpreted correctly when uploaded back into RideWithGPS. From what I can see, RideWithGPS seems to do a check that the "Name" of a CoursePoint entry must exist in the "Notes" entry. 

For example, when cycle.travel has turn instructions, say "Turn right onto Shrigley Road", followed by "Turn right", it creates two  CoursePoint entries both with Name "ShrigleyRo". RideWithGPS doesn't interpret either of these correctly.

The first one is interpreted correctly if the Name is changed from "ShrigleyRo" to "Shrigley R". It doesn't appear to like the removal of the embedded space. 

The second one is interpreted correctly if the Name is changed from "ShrigleyRo" to "Turn Right". It doesn't interpret "Shrigley R" as this is not in the Notes for this turn.

Richard - I don't know if you consider this worth changing. I have used PlotARoute and it interprets the cycle.travel TCX files correctly, as does the Bike Tracker navigation app. I cannot see why RideWithGPS does this check ... but it does !